As I had issues with the large download of the preconfigured VM, I'm creating it myself as per the instructions. When running the config script, there is a fatal error when downloading rottenpotatoes. Since I am new to git, I'm curious to know if I'm just missing something obvious. this is the command in the script that fails:

git clone git://github.com/saasbook/rottenpotatoes

Then there is :

git checkout -b ch_ruby_intro origin/ch_ruby_intro

I don't find any branches in either the hw2 or hw3..?

Has anyone else dealt with this? Thanks

asked 13 Feb '12, 19:31

tonesfrommars's gravatar image


edited 13 Feb '12, 19:34

Gundega's gravatar image


There's no repository named "rottenpotatoes". There are repositories named:

  1. git://github.com/saasbook/hw2_rottenpotatoes.git
  2. git://github.com/saasbook/hw3_rottenpotatoes.git

I found this out by going to the Saas github page in a browser and looking at the 7 public repositories in the list. You can then click on http/git/etc to see the information I pasted in here. The only branch I see in the hw2 and hw3 repos is master though.

The branch ch_ruby_intro wouldn't exist because the checkout command with the -b flag tells git to create a new branch for you. And I believe origin/ch_ruby_intro is what registers the feature as a feature branch. Not positive about this last sentence though.


answered 13 Feb '12, 23:45

Jeanne%20Boyarsky's gravatar image

Jeanne Boyarsky

I've the same problem.
The download doesn't work, I've tried 3 times, the first stop at 1,69 GB (less that 50 MB to the end) the second at 1Gb, the third at 1,7GB ( less the 40 mb to the end), I'm very very disappointed.
I've tried with Linux Mint you can find the result on this post)

Finally I follow the instruction step by step with VirtualBox and Ubuntu 32bit, same result.

I hope that when the course starts the professors will fix the link, if this doesn't happen I simply drop the course due to lack professionalism.


answered 14 Feb '12, 06:12

AINeko's gravatar image


Hi AlNeko: In defence of the profs, the script does note in the comments that it is fragile due to the possibility of links changing/moving. Also, the method we are using is not officially supported, so I expected to have to figure some things out for myself. I don't think there's a lack of professionalism here, rather these challenges are par for the course in any endeavor involving software (particularly developing it!) I hope you stick with it. I am looking forward to the course. best
(20 Feb '12, 22:17) tonesfrommars tonesfrommars's gravatar image
Your answer
toggle preview

Follow this Question via Email

Once you sign in you will be able to subscribe for any updates here

Q&A Editor Basics

  • to upload an image into your question or answer hit
  • to create bulleted or numbered lists hit or
  • to add a title or header hit
  • to section your text hit
  • to make a link clickable, surround it with <a> and </a> (for example, <a>www.google.com</a>)
  • basic HTML tags are also supported (for those who know a bit of HTML)
  • To insert an EQUATION you can use LaTeX. (backslash \ has to be escaped, so in your LaTeX code you have to replace \ with \\). You can see more examples and info here